PSTN Network Outage in CHINA
Incident Report for Pexip Service
Resolved
After an extended monitoring period we have not observed any further service disruption.
Posted Jun 21, 2018 - 01:50 UTC
Monitoring
The PSTN service is now operating normally within mainland China, we will continue to monitor.
Posted Jun 19, 2018 - 06:55 UTC
Investigating
An outage on the PSTN network for the Videxio service within China has been identified.

We are currently investigating the cause of this outage.

In the meantime we recommend that users in China connect via the Hong Kong number (+852 5808 1308) until further notice.
Posted Jun 19, 2018 - 06:16 UTC
This incident affected: PSTN access.