PSTN dial-in number in United States is currently experiencing a network outage.
Incident Report for Pexip Service
Resolved
Our PSTN partner in the United States has resolved their network outage, PSTN calling in the United States is fully operational.
Posted Aug 07, 2018 - 14:30 UTC
Monitoring
Our PSTN provider has returned the US phone number service, however, we are currently awaiting notice that the issue has been resolved completely.
Posted Aug 07, 2018 - 14:38 UTC
Investigating
Our PSTN partner in United States that handles local dial-in numbers is currently experiencing a network outage. The partner is aware of it and is actively working on a quick resolution.

Alternatively users can dial +14695320735 while the main phone number is out.
Posted Aug 07, 2018 - 07:51 UTC
This incident affected: PSTN access.