User account activation links experience issues
Incident Report for Pexip Service
Resolved
The Operations team has fixed the issue with user account activation links.

No further issues have been observed or reported and all systems are operational at this time.
Posted Feb 08, 2018 - 09:15 UTC
Investigating
The Operations has found an issue with the user account activation and is currently working on a fix.

Symptom: activating new accounts or resetting user passwords shows "Invalid invitation" message in the account activation page.
Posted Feb 08, 2018 - 07:38 UTC